MEDIUMCVSS v3.1 5.4Vulnerability
CVE-2026-121652
Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later.
Properties
- Severity
- MEDIUM
- Nvd fetched at
- 2026-11-03T21:24:30.963596+00:00
- Cvss score
- 5.4
- Cvss severity
- MEDIUM
- Retrieved at
- 2026-11-03T21:25:36+00:00
- Score
- 5.4
- Last source
- NVD
- Cvss version
- 3.1
- Cve id
- CVE-2026-121652
- Cvss vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- First seen by Signal
- 2026-11-03T21:21:12+00:00
- Vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Published at
- 2026-11-03T19:18:05.363
- Last modified
- 2026-11-03T20:18:13.460
Related Entities (1)
HAS_WEAKNESS (1)
Explore deeper with Ninja Signal's threat intelligence graph