MEDIUMCVSS v3.1 4.3Vulnerability
CVE-2026-120597
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
Properties
- Severity
- MEDIUM
- Nvd fetched at
- 2026-11-04T01:29:06.847378+00:00
- Epss score
- 0.00278
- Cvss score
- 4.3
- Cvss severity
- MEDIUM
- Retrieved at
- 2026-11-04T01:32:28+00:00
- Score
- 4.3
- Last source
- FIRST EPSS
- Cvss version
- 3.1
- Cve id
- CVE-2026-120597
- Cvss vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- First seen by Signal
- 2026-11-03T00:56:41+00:00
- Name
- CVE-2026-120597
- Vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N
- Published at
- 2026-11-02T23:17:19.960
- Last modified
- 2026-11-03T19:17:59.480
- Epss percentile
- 0.20363
Related Entities (2)
HAS_WEAKNESS (2)
Explore deeper with Ninja Signal's threat intelligence graph