HIGHCVSS v4 8.6Vulnerability

CVE-2026-118668

## Summary LangGraph deployments using JavaScript or TypeScript custom authentication may fail to apply Store authorization changes returned by an authorization handler. In affected deployments, an authenticated user may be able to access Store data outside their authorized namespace. ## Required conditions A deployment is affected only when all of the following conditions apply: - It uses an affected `langgraph-api` version. - It runs JavaScript or TypeScript custom authentication. - Its Store authorization handler relies on rewriting the requested namespace to restrict each user to their own data. - The attacker can authenticate as an ordinary user. - Multiple users' data is stored through the affected authorization path. Python custom authentication handlers are not affected. JavaScript or TypeScript handlers that reject unauthorized namespace requests instead of rewriting them are also not affected. The attack does not require administrator privileges, user interaction, a race condition, or the bypass of another mitigation. ## Impact An authenticated user may be able to read, overwrite, search, or delete Store data belonging to another user. ## Patches The issue is fixed in `langgraph-api` version `0.15.0`. The server now carries changes made by a JavaScript or TypeScript authorization handler across the runtime boundary and applies them before performing the Store operation. It validates the resulting namespace after authorization and rejects the request if an authorization change is malformed or cannot be applied safely. Users should upgrade to `langgraph-api>=0.15.0`. ## Workarounds Deployments that cannot upgrade immediately should change JavaScript or TypeScript Store authorization handlers to reject requests for unauthorized namespaces rather than relying on namespace rewriting. This workaround must be applied to every Store action exposed by the deployment.

Properties

Summary
LangGraph JavaScript custom authentication may permit cross-user Store access
Severity
high
Nvd fetched at
2026-10-28T23:43:43.157973+00:00
Cvss score
8.6
Cvss severity
HIGH
Retrieved at
2026-10-28T23:45:48+00:00
Ghsa published
2026-10-28T21:09:42Z
Source url
https://github.com/advisories/GHSA-4hm6-w6qq-w73v
Ghsa updated
2026-10-28T21:09:43Z
Ghsa id
GHSA-4hm6-w6qq-w73v
Last source
GitHub Advisory Database
Score
8.6
Cvss version
4.0
Cve id
CVE-2026-118668
Cvss vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
First seen by Signal
2026-10-28T23:44:40+00:00
Is ghsa only
false
Vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published at
2026-10-28T21:16:57.263
Last modified
2026-10-28T21:16:57.373

Related Entities (4)

AFFECTS (1)

→[Software]pip/langgraph-api

VULNERABLE_TO (1)

←[Software]pip/langgraph-api

Explore deeper with Ninja Signal's threat intelligence graph

CVE-2026-118668 (CVSS v4 8.6) — Ninja Signal Threat Intelligence | Ninja Signal